import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(background:\\s*url\\((https?:\\/\\/)*[a-zA-Z0-9._:\\/\\s*]*\\)\\s*[a-zA-Z0-9\\s*-._:\\/;]*)";
final String string = ".nyroModalCloseButton {\n"
+ " top: -13px;\n"
+ " right: -13px;\n"
+ " width: 12px;\n"
+ " height: 12px;\n"
+ " text-indent: -9999em;\n"
+ " background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;\n"
+ "}\n\n"
+ ".nyroModalCloseButton {\n"
+ " top: -13px;\n"
+ " right: -13px;\n"
+ " width: 12px;\n"
+ " height: 12px;\n"
+ " text-indent: -9999em;\n"
+ " background: url(https://instant/templates/_default_/images/nyromodal/close.gif);\n"
+ "}\n"
+ ".nyroModalCloseButton {\n"
+ " top: -13px;\n"
+ " right: -13px;\n"
+ " width: 12px;\n"
+ " height: 12px;\n"
+ " text-indent: -9999em;\n"
+ " background: url(../instant/templates/_default_/images/nyromodal/close.gif);\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}