using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:(?:in\s|out\s)?([\w.]+))(?:(?:, ?)((?:in\s|out\s)?[\w.]+))+?>";
string input = @"public void Foo<out Bar.Baz, Dude>(string baz) {";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}