$re = '/<(?:(?:in\s|out\s)?([\w.]+))(?:(?:, ?)((?:in\s|out\s)?[\w.]+))+?>/';
$str = 'public void Foo<out Bar.Baz, Dude>(string baz) {';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);