const regex = /<(?:(?:in\s|out\s)?([\w.]+))(?:(?:, ?)((?:in\s|out\s)?[\w.]+))+?>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:(?:in\\s|out\\s)?([\\w.]+))(?:(?:, ?)((?:in\\s|out\\s)?[\\w.]+))+?>', '')
const str = `public void Foo<out Bar.Baz, Dude>(string baz) {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}