re = /<(?:(?:in\s|out\s)?([\w.]+))(?:(?:, ?)((?:in\s|out\s)?[\w.]+))+?>/
str = 'public void Foo<out Bar.Baz, Dude>(string baz) {'
# Print the match result
str.match(re) do |match|
puts match.to_s
end