# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(([^"]*"){2})*[^"]*$)(?=(([^']*'){2})*[^']*$)\s*,\s*/\n/g;t' <<< "abcd, efgh, ij\"k,l\", mnop, 'q,rs't"