import Foundation
let pattern = #"(?=(([^"]*"){2})*[^"]*$)(?=(([^']*'){2})*[^']*$)\s*,\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abcd, efgh, ij"k,l", mnop, 'q,rs't"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)