$re = '/(?=(([^"]*"){2})*[^"]*$)(?=(([^\']*\'){2})*[^\']*$)\s*,\s*/';
$str = 'abcd, efgh, ij"k,l", mnop, \'q,rs\'t';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;