#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[A-Z]{2}[-|_][A-Z]{1}[-|_][a-zA-Z]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9A-Z]{2}[-|_][A-Z]{3}[-|_][\w]{1,30}[-|_]LOD[0123]00"
Local $sString = "YP-A-Ss_25_10_20-M3-CWS-Curtain_Wall-LOD200"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)