// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{2}[-|_][A-Z]{1}[-|_][a-zA-Z]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9A-Z]{2}[-|_][A-Z]{3}[-|_][\w]{1,30}[-|_]LOD[0123]00").unwrap();
let string = "YP-A-Ss_25_10_20-M3-CWS-Curtain_Wall-LOD200";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}