using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{2}[-|_][A-Z]{1}[-|_][a-zA-Z]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9A-Z]{2}[-|_][A-Z]{3}[-|_][\w]{1,30}[-|_]LOD[0123]00";
string substitution = @"";
string input = @"YP-A-Ss_25_10_20-M3-CWS-Curtain_Wall-LOD200";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}