re = /[A-Z]{2}[-|_][A-Z]{1}[-|_][a-zA-Z]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9]{2}[-|_][0-9A-Z]{2}[-|_][A-Z]{3}[-|_][\w]{1,30}[-|_]LOD[0123]00/m
str = 'YP-A-Ss_25_10_20-M3-CWS-Curtain_Wall-LOD200'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result