$re = '/#{+[^#{]+}+/i';
$str = '첫번째#{가나다라마바사}1234567
';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;