package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-\s?\([^)]+\).+?\w+:\w+`)
var str = `- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:(NSString *)deltaValueString {
- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
- (void)transitionToValue:valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
[self test:asd]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}