import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\s?\\([^)]+\\).+?\\w+:\\w+";
final String string = "- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:(NSString *)deltaValueString {\n"
+ "- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {\n"
+ "- (void)transitionToValue:valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {\n"
+ "[self test:asd]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}