$re = '/-\s?\([^)]+\).+?\w+:\w+/';
$str = '- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:(NSString *)deltaValueString {
- (void)transitionToValue:(NSString *)valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
- (void)transitionToValue:valueString withUnit:(NSString *)unitString deltaValue:deltaValueString {
[self test:asd]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);