#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^_\s]+)_([^._\s]+)(?:\.[^._\s]+)?_([^_\s]+)"
Local $sString = "aabb_cc.dd_eeff" & @CRLF & _
"aabb_ccdd_eeff" & @CRLF & _
"aabb_cc.dd_eeff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")