package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^_\s]+)_([^._\s]+)(?:\.[^._\s]+)?_([^_\s]+)`)
var str = `aabb_cc.dd_eeff
aabb_ccdd_eeff
aabb_cc.dd_eeff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}