using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^_\s]+)_([^._\s]+)(?:\.[^._\s]+)?_([^_\s]+)";
string input = @"aabb_cc.dd_eeff
aabb_ccdd_eeff
aabb_cc.dd_eeff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}