re = /([^_\s]+)_([^._\s]+)(?:\.[^._\s]+)?_([^_\s]+)/m
str = 'aabb_cc.dd_eeff
aabb_ccdd_eeff
aabb_cc.dd_eeff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end