#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]{2}-?\s?[0-9]{3}[A-Z]{2})+"
Local $sString = "klajshf lkjsh allashflkjh BL-345HS sjhg qkjg ZA-456KL qwkjh g" & @CRLF & _
"qwdewqdwqedwqd BL345HS wqedwqehdljhwqed ZA 456KL" & @CRLF & _
"sdcscd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")