$re = '/([A-Z]{2}-?\s?[0-9]{3}[A-Z]{2})+/m';
$str = 'klajshf lkjsh allashflkjh BL-345HS sjhg qkjg ZA-456KL qwkjh g
qwdewqdwqedwqd BL345HS wqedwqehdljhwqed ZA 456KL
sdcscd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);