import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{2}-?\\s?[0-9]{3}[A-Z]{2})+";
final String string = "klajshf lkjsh allashflkjh BL-345HS sjhg qkjg ZA-456KL qwkjh g\n"
+ "qwdewqdwqedwqd BL345HS wqedwqehdljhwqed ZA 456KL\n"
+ "sdcscd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}