package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]{2}-?\s?[0-9]{3}[A-Z]{2})+`)
var str = `klajshf lkjsh allashflkjh BL-345HS sjhg qkjg ZA-456KL qwkjh g
qwdewqdwqedwqd BL345HS wqedwqehdljhwqed ZA 456KL
sdcscd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}