package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[([^\]|]|)?([^\]]*)\]\]`)
var str = `hfksadf ndkflkadsfä jfdsäafj Jfkjsa
kjdsafsa fskjdfdsa [[Hokolores]][[Hallo Spencer|Spencer]] fdsjfhdskjf lkjfds
fdslkajfskadf
fdskfdlskjf [[Krutzekrupp]]
fdskljfldsaf
kjdsafsa fskjdfdsa [[Krumzack]][[Odelalla Jugano|DHVc]] fdsjfhdskjf lkjfds
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}