$re = '/\[\[([^\]|]|)?([^\]]*)\]\]/m';
$str = 'hfksadf ndkflkadsfä jfdsäafj Jfkjsa
kjdsafsa fskjdfdsa [[Hokolores]][[Hallo Spencer|Spencer]] fdsjfhdskjf lkjfds
fdslkajfskadf
fdskfdlskjf [[Krutzekrupp]]
fdskljfldsaf
kjdsafsa fskjdfdsa [[Krumzack]][[Odelalla Jugano|DHVc]] fdsjfhdskjf lkjfds
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);