re = /\[\[([^\]|]|)?([^\]]*)\]\]/m
str = 'hfksadf ndkflkadsfä jfdsäafj Jfkjsa
kjdsafsa fskjdfdsa [[Hokolores]][[Hallo Spencer|Spencer]] fdsjfhdskjf lkjfds
fdslkajfskadf
fdskfdlskjf [[Krutzekrupp]]
fdskljfldsaf
kjdsafsa fskjdfdsa [[Krumzack]][[Odelalla Jugano|DHVc]] fdsjfhdskjf lkjfds
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end