import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[([^\\]|]|)?([^\\]]*)\\]\\]";
final String string = "hfksadf ndkflkadsfä jfdsäafj Jfkjsa \n\n"
+ "kjdsafsa fskjdfdsa [[Hokolores]][[Hallo Spencer|Spencer]] fdsjfhdskjf lkjfds\n\n"
+ "fdslkajfskadf\n"
+ "fdskfdlskjf [[Krutzekrupp]]\n\n"
+ "fdskljfldsaf\n\n"
+ "kjdsafsa fskjdfdsa [[Krumzack]][[Odelalla Jugano|DHVc]] fdsjfhdskjf lkjfds\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}