use strict;
my $str = 'a b c
ab c d ef
abcde
A E O TEST';
my $regex = qr/(?<=\b\w)\s(?=\w\b)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";