import Foundation
let pattern = #"(?<=\b\w)\s(?=\w\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a b c
ab c d ef
abcde
A E O TEST
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)