re = /(?<=\b\w)\s(?=\w\b)/
str = 'a b c
ab c d ef
abcde
A E O TEST'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result