$re = '/(?<=\b\w)\s(?=\w\b)/';
$str = 'a b c
ab c d ef
abcde
A E O TEST';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;