#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.0+$|^(-)?0+(?=\.)"
Local $sString = "2.0" & @CRLF & _
"3.00" & @CRLF & _
"-4.0" & @CRLF & _
"0.00" & @CRLF & _
"-0.00" & @CRLF & _
"0.03" & @CRLF & _
"2.01" & @CRLF & _
"0.001" & @CRLF & _
"-0.03" & @CRLF & _
"101"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)