# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.0+$|^(-)?0+(?=\.)"
test_str = ("2.0\n"
"3.00\n"
"-4.0\n"
"0.00\n"
"-0.00\n"
"0.03\n"
"2.01\n"
"0.001\n"
"-0.03\n"
"101")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.