using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.0+$|^(-)?0+(?=\.)";
string substitution = @"$1";
string input = @"2.0
3.00
-4.0
0.00
-0.00
0.03
2.01
0.001
-0.03
101";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}