import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.0+$|^(-)?0+(?=\\.)";
final String string = "2.0\n"
+ "3.00\n"
+ "-4.0\n"
+ "0.00\n"
+ "-0.00\n"
+ "0.03\n"
+ "2.01\n"
+ "0.001\n"
+ "-0.03\n"
+ "101";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}