using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Rathi.*25 mm";
string input = @"Rathi Stelmax 500 25 mm";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}