package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Rathi.*25 mm`)
var str = `Rathi Stelmax 500 25 mm`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}