$re = '/Rathi.*25 mm/';
$str = 'Rathi Stelmax 500 25 mm';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);