const regex = /Rathi.*25 mm/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Rathi.*25 mm', '')
const str = `Rathi Stelmax 500 25 mm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}