using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\""[^\""]*\""\)";
string substitution = @"\1(""0.1.2.3"")";
string input = @"# C#
[assembly: AssemblyCopyright("")]
[assembly: AssemblyTrademark("")]
[assembly: AssemblyCulture("")]
[assembly: AssemblyVersion(""1.1.0.0"")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile("")]
[assembly: AssemblyKeyName("")]
[assembly: AssemblyInformationalVersion(""1.0.0 JRC"")]
# VBasic
<Assembly: AssemblyCulture("")>
<Assembly: AssemblyVersion(""1.1.0.0"")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile("")>
<Assembly: AssemblyKeyName("")>
<Assembly: AssemblyInformationalVersion(""1.0.0 JRC"")>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}