re = /(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)/m
str = '# C#
[assembly: AssemblyCopyright("")]
[assembly: AssemblyTrademark("")]
[assembly: AssemblyCulture("")]
[assembly: AssemblyVersion("1.1.0.0")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile("")]
[assembly: AssemblyKeyName("")]
[assembly: AssemblyInformationalVersion("1.0.0 JRC")]
# VBasic
<Assembly: AssemblyCulture("")>
<Assembly: AssemblyVersion("1.1.0.0")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile("")>
<Assembly: AssemblyKeyName("")>
<Assembly: AssemblyInformationalVersion("1.0.0 JRC")>
'
subst = '\\1("0.1.2.3")'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result