use strict;
my $str = '# C#
[assembly: AssemblyCopyright("")]
[assembly: AssemblyTrademark("")]
[assembly: AssemblyCulture("")]
[assembly: AssemblyVersion("1.1.0.0")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile("")]
[assembly: AssemblyKeyName("")]
[assembly: AssemblyInformationalVersion("1.0.0 JRC")]
# VBasic
<Assembly: AssemblyCulture("")>
<Assembly: AssemblyVersion("1.1.0.0")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile("")>
<Assembly: AssemblyKeyName("")>
<Assembly: AssemblyInformationalVersion("1.0.0 JRC")>
';
my $regex = qr/(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)/mp;
my $subst = '\\1("0.1.2.3")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";