// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)"#).unwrap();
let string = "# C#
[assembly: AssemblyCopyright(\"\")]
[assembly: AssemblyTrademark(\"\")]
[assembly: AssemblyCulture(\"\")]
[assembly: AssemblyVersion(\"1.1.0.0\")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile(\"\")]
[assembly: AssemblyKeyName(\"\")]
[assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")]
# VBasic
<Assembly: AssemblyCulture(\"\")>
<Assembly: AssemblyVersion(\"1.1.0.0\")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile(\"\")>
<Assembly: AssemblyKeyName(\"\")>
<Assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")>
";
let substitution = "\\1(\"0.1.2.3\")";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}