package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]{2,}|[a-z][0-9]{2,})[0-9]*$`)
var str = `tt
tt2
test
a11
t2
t
1
t1t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}