$re = '/^([a-z]{2,}|[a-z][0-9]{2,})[0-9]*$/m';
$str = 'tt
tt2
test
a11
t2
t
1
t1t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);