import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]{2,}|[a-z][0-9]{2,})[0-9]*$";
final String string = "tt\n"
+ "tt2\n"
+ "test\n"
+ "a11\n\n"
+ "t2\n"
+ "t\n"
+ "1\n"
+ "t1t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}