// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z]{2,}|[a-z][0-9]{2,})[0-9]*$").unwrap();
let string = "tt
tt2
test
a11
t2
t
1
t1t";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}