package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[%User\.(?<usernr>\d+?)%]`)
var str = `Hallo ich bin der [%User.123456789%], und ich bin ebenfalls ein User mit dem Namen [%User.987654321%]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}