$re = '/\[%User\.(?<usernr>\d+?)%]/m';
$str = 'Hallo ich bin der [%User.123456789%], und ich bin ebenfalls ein User mit dem Namen [%User.987654321%]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);